Blocks

Description

Donald wishes to send a gift to his new nephew, Fooey. Donald is a bit of a traditionalist, so he has chosen to send a set of N classic baby blocks. Each block is a cube, 1 inch by 1 inch by 1 inch. Donald wants to stack the blocks together into a rectangular solid and wrap them all up in brown paper for shipping. How much brown paper does Donald need?

Input

The first line of input contains C, the number of test cases. For each case there is an additional line containing N, the number of blocks to be shipped. N does not exceed 1000.

Output

Your program should produce one line of output per case, giving the minimal area of paper (in square inches) needed to wrap the blocks when they are stacked together.

Sample Input

5
9
10
26
27
100

Sample Output

30
34
82
54
130

分析:枚举,堆积起来的体积为ijk,则num%(i*j)肯定为整数,然后更新表面积得到最小即可。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include<iostream>
#include<algorithm>
#include<vector>
#include<cctype>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
void solve();
int main()
{
solve();
return 0;
}
void solve()
{
int t,i,j,m,num,ans,now;
cin>>t;
while(t--)
{
ans=999999999;
cin>>num;
for(i=1;i<=num;i++)
{
for(j=1;j*i<=num;j++)
{
if(num%(i*j)!=0)
continue;
m=num/(i*j);
now=i*j+i*m+m*j;
if(now<ans)
ans=now;
}
}
cout<<ans*2<<endl;
}
}

打个小广告

欢迎加入我的小专栏「基你太美」一起学习。