1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

思路:题意是算出最早签到的人和最晚签离的人,所以只要把时间化成与00:00:00的差值即可,换算成秒,求出最小和最大即可。

Code:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,i;
    scanf("%d",&n);
    char fir[16],last[16],temp[16];
    int s,f,m;
    int min=99999,max=-1;
    for(i=0;i<n;i++)
    {
        scanf("%s %d:%d:%d",temp,&s,&f,&m);
        int ti=3600*s+60*f+m;
        if(ti<min)
        {
            min=ti;
            strcpy(fir,temp);
        }
        scanf("%d:%d:%d",&s,&f,&m);
        ti=3600*s+60*f+m;
        if(ti>max)
        {
            max=ti;
            strcpy(last,temp);
        }
    }
    printf("%s %s\n",fir,last);
    return 0;
}

打个小广告

欢迎加入我的小专栏「基你太美」一起学习。